読者です 読者をやめる 読者になる 読者になる

Macbook Air 2012(mid) にvim-rubyを入れた

Macbook Air 2012(mid) が手に入ったので、いつものごとくvim-rubyを入れました。

以前のポスト

例のごとく、vimrubyに対応してるか確認すると、

mba:~ kazuki.yunoue$ vi --version | grep ruby
-python3 +quickfix +reltime -rightleft +ruby/dyn +scrollbind +signs

あら、対応してる。最近から?

以前の通り、

git clone http://github.com/vim-ruby/vim-ruby.git
cd vim-ruby
git checkout vim7.3

rake package

直接ソースからgemのパッケージを作成してinstallしようとすると、

mba:vim-ruby kazuki.yunoue$ rake package
rake aborted!
ERROR: 'rake/gempackagetask' is obsolete and no longer supported. Use 'rubygems/package_task' instead.

rakeのバージョンとの親和性が良くないのか怒られる。

仕方がないので、ココのpathogen.vim方法と思わせてManuallyに、

https://github.com/vim-ruby/vim-ruby/wiki/VimRubySupportA

./bin/vim-ruby-install.rb

これで~/.vim/下に必要なファイルがコピーされるので、

vi ~/.vimrc

に、

set tabstop=2
set shiftwidth=2
set expandtab
set autoindent
set nocompatible
syntax on
filetype on
filetype indent on
filetype plugin on

とか書いてしまえば、完了だ!